oil pressure

Technical questions and answers
Post Reply
Rob
Posts: 39
Joined: Fri Oct 26, 2007 3:50 pm
Location: Walsall

oil pressure

Post by Rob »

there was a leak on the engine, the front axle was wet, the oil
pressure switch was leaking so I replaced that. the green oil
pressure light goes out soon it fires up, but my pressure
gauge is reading very low at idling speed, just off the white
mark and doesn't move very much when revved up a bit.
it was working fine before. I've not changed the oil for
2000 miles, not for the last couple years, it doesn't got used
very much. it's got 81000 miles on the clock. any answers,
please? :(
User avatar
Larry
Posts: 205
Joined: Thu Feb 08, 2007 3:18 pm
Location: Derby, UK

Post by Larry »

Don't know if this helps, but the oil pressure relief spring on mine got jammed and showed similar symptoms. Its located on the oil pressure sender/pump body (just above the axle) and consists of a spring and piston.

At first I took it apart and cleaned it up and it worked for a bit then jammed again. Tight fisted here then found out that the overhaul kit wasn't very expensive and fitted that. Solved the problem.

If the leak drained the oil pump, it may be that it isn't pumping oil round the system. Now the leak is solved, it may just need repriming (packing) with Vasoline and refitting.
Larosto
Posts: 83
Joined: Thu Jan 11, 2007 2:56 pm
Location: Germany, N

Post by Larosto »

Hi,

when rebuilding my engine, I instaled new gears to the oilpump. I didn`t prime it with vaseline, but by an other way: I took al sparks out, and instaled a good battery. I filled the oilpump with engine oil, and then the oilpump was primed by starting the engine without spark plugs. Worked good. I think this is easier.
Hope this helps.

good luck

Horst
Rob
Posts: 39
Joined: Fri Oct 26, 2007 3:50 pm
Location: Walsall

Post by Rob »

Started the landy up today and let it warm up.
Revved the V8 up and the needle on the pressure
gauge did move though not much. Is it not changing
the oil for last 2 years, 2000 miles since last oil
change making pressure low?
stirlsilver
Posts: 338
Joined: Tue Nov 21, 2006 9:45 am
Location: Wheelers Hill, Victoria, Australia
Contact:

Post by stirlsilver »

Doubt it. One thing is that your oil pressure might be fine but the gauge is playing up on you. If the oil light is not coming on and there isn't a tapping noise coming from the engine I would say that you have sufficient oil pressure.

If you want more solid proof. Take off one of the tappet covers and start the engine and see if you have oil dripping off the rockers. If you do then your oil pressure is ok.
User avatar
Larry
Posts: 205
Joined: Thu Feb 08, 2007 3:18 pm
Location: Derby, UK

Post by Larry »

Further to Stirlsilvers post, is the oil pressure gauge one of the ones that operate on a capiliary pipe from the oil pump area. If so, it could well be that the pipe is gunged up and therefore there is no or little reading on the dial.

Is the green oil pressure light going completely out and staying out? The light can flicker and glow slightly with minor pressure problems and can be difficult to notice in daylight.
Rob
Posts: 39
Joined: Fri Oct 26, 2007 3:50 pm
Location: Walsall

Post by Rob »

the green light goes out soon as the engine fires up!
forgot to mention that! sorry.
Tattiebogle
Posts: 58
Joined: Wed Jan 09, 2008 4:00 pm
Location: Logie Nr. Glamis Castle

Post by Tattiebogle »

I,m having a similar problem with mine..When started from cold the light goes out no problem and the gauge reads 5psi..If i go for a run then just let the motor idle the green light comes on and the gauge reads zero , then if i rev it up a bit the light goes off and the gauge creeps back up to 5psi..There is no rattles from engine but i think things could be better here..Any suggestions?? Where exactly is the spring and ballbearing valve , is it actualy in the oil filter housing??
Kippa
Posts: 49
Joined: Tue Apr 01, 2008 9:16 pm
Location: Kent

oil pressure switch

Post by Kippa »

I appear to have the same leak on my engine, my front axle is also wet with oil, is it a common problem. Do I need to drain/change the oil to change the oil pressure switch, how difficult is it ?
Post Reply